Linux-Bulgaria.ORG
навигация

 

начало

пощенски списък

архив на групата

семинари ...

линукс учебник

документи

как да ...

 

 

Предишно писмо Следващо писмо Предишно по тема Следващо по тема По Дата По тема (thread)

Re: [Lug-bg] ZFS Root на HP DL380p Gen8 с HP H220 HBA (LSI 9207-8i)


  • Subject: Re: [Lug-bg] ZFS Root на HP DL380p Gen8 с HP H220 HBA (LSI 9207-8i)
  • From: Todor Belev <todorin@xxxxxx>
  • Date: Mon, 17 Jun 2019 13:26:21 +0300 (EEST)

Би трябвало с Redhat да работят тия сервери.

с Уважение,
Тодор Белев
0898303366




-------- Оригинално писмо --------
От: Dimitar Grigorov dimitar.grigorov@xxxxxxxxxxxxx
Относно: [Lug-bg] ZFS Root на HP DL380p Gen8 с HP H220 HBA (LSI 9207-8i)
До: lug-bg@xxxxxxxxxxxxxxxxxx
Изпратено на: 17.06.2019 13:11

Здравейте,
имам проблем с boot на Debian със ZFS root. След инсталация по начина описан в този guide дава тази грешка: 
error no such device: 1d3d5862b1f5f148
error: unknown filesystem.
Entering rescue mode...

Хардуер:
    Сървър: HP ProLiant DL380p Gen8. Има 25-bay-a за двуинчови дискове.
    HBA: HP H220 с рефлашнат firmware за LSI 9207-8i както е описано в този guide
    Дискове: WD Black 1TB, 2.5", WDC WD10JPLX-00MBPT0. Physical sector side: 4k; Logical 512 bytes. Знам, че са зле..

От guide-a са пропускани частите свързани с UEFI (понеже сървъра няма UEFI) и LUKS.
Проблема се появява само, когато ZFS-а е в RAID-Z.
При преместване на дисковете на Desktop машина(без HBA-то) - OS-a boot-ва.
При инсталация на ZFS Root върху един диск - няма проблем.
При инсталация на Debian в софтуерен RAID (mdadm) - няма проблем.
Опитвах и с Proxmox, чиято елементарна инсталация предлага ZFS root. Същото е поведението както при стандартен Debian.
Обърнах внимание на частта в guide-a MPT2SAS, в която е описано, че тези HBA-та по-бавно detect-ват дисковете, но описаното там не помогна.
В "BIOS-a" на HBA-то са вдигнати timeout-ите за detect на дисковете.

След няколко неуспешни опита е обновен BIOS-a на сървъра, както и всички останали firmware-и до последни версии.
Не съм опитвал да буутвам на друга машина с това HBA.
Имам успешно инсталирани други два Dell сървъра с подобна хардуерна и софтуерна конфигурация.

Имах сървър без дискове, който се опитвам да "съживя" и да използвам за тестове с виртуалки.
Сървъра няма да се използва за нищо сериозно(което иска надеждност и 24/7 uptime), затова гледах да намаля разходите избирайки подобна хардуерна и софтуерна конфигурация.

Някой сблъсквал ли се е с подобен проблем и може ли да ме насочи към решението му?
Винаги остава варианта да използвам две SSD-та в RAID 1 за boot/root, ако няма друго решение.



Avast logo

Този имейл е проверен за вируси от Avast.
www.avast.com


_______________________________________________
Lug-bg mailing list
Lug-bg@xxxxxxxxxxxxxxxxxx
http://linux-bulgaria.org/mailman/listinfo/lug-bg


 

наши приятели

 

линукс за българи
http://linux-bg.org

FSA-BG
http://fsa-bg.org

OpenFest
http://openfest.org

FreeBSD BG
http://bg-freebsd.org

KDE-BG
http://kde.fsa-bg.org/

Gnome-BG
http://gnome.cult.bg/

проект OpenFMI
http://openfmi.net

NetField Forum
http://netField.ludost.net/forum/

 

 

Linux-Bulgaria.ORG

Mailing list messages are © Copyright their authors.

Hosted by SiteGround Inc